TCP/IP working under booloader, but not under CE

Apr 17, 2008 at 6:03 AM
First of all, thanks David for creating and sharing this BSP!

I have it installed and running, however I am not able to ping my PC from the gumstix and my PC cannot ping the gumstix. The remote display-over-IP application does not work either (not surprising given that ping doesn't work).

I have installed your pre-built NK.bin on a Gumstix Verdex XM4, with console-vx and netmicro-sd expansion boards.
My configuration word is 80005049.
The LCD display works, as does the console serial connection.
No errors are reported over the serial connecting during bootup.
I am able to download NK.bin over TCP/IP, so the hardware works, and the bootloader is able to use it.
However, as noted above, TCP/IP doesn't work from within CE.
The link light is on at my hub.
I am using static addresses on my network, and I have set the gumstix address to 192.168.0.2 in both the boot loader setup menu and in the network connections control panel applet. Persistent registry is working, so the gumstix IP address, netmask, and gateway are set correctly when CE boots up.
When I run "ping -t 192.168.0.1" in the console window on the gumstix, I get a series of errors: "transmit failed, error code 11010"
When I run "ping 192.168.0.2" (gumstix pinging itself) I get no errors, the ping works fine.

Do you have any idea what could be wrong and how to fix this problem?
Is there any other information that would help to diagnose it?

Thanks!
Apr 17, 2008 at 1:12 PM
Edited Apr 17, 2008 at 1:14 PM
Hello Nate, great to here from you!

This is how I would proceed:
Disable persistent registry first (use 0x00005049).
Reboot and try to ping 192.168.0.6
This is the default static IP set in the prebuilt image for the netMicro.
Looks like you have the PC correctly set at 192.168.0.1
Both need net mask of 255.255.255.0
Should be able ping, telnet, ftp and web browse this address.

Remember if you change the settings through the network control panel you will probably have to "disable" and "enable" to get the setting to rebind.
Or if you are using the persistent registry, do a "registry flush" after setting, then reboot.

I recently moved (see latest change set) the default TCP/IP NIC setting from platform.reg to project.reg for easier modification.


Let me know how it goes.

Good luck,
DV


Apr 24, 2008 at 3:42 AM
Thanks David. It turned out to be a mistake on my part - I initially gave the gumstix a MAC address of 11-22-33-44-55-66. The problem went away after I assigned it the address that it had when it arrived from Gumstix (D6-4A-etc, etc). Ping and http are working now.

So today I learned about the significance of the lowest bit in the first byte of a MAC address: multicast vs. unicast.